Get Adobe Flash player

SharePoint

SharePoint authentication window pops up when opening document library in Explorer View [solved]

VN:F [1.9.22_1171]
Rating: 5.0/5 (1 vote cast)

If you want to open a document library with “Open with Windows Explorer” you use the WebDAV protocol to list the folder contents on a SharePoint. This can be very helpful if you need to copy a lot of files from or to your computer. Opening the Explorer View on a Windows 7 computer you get an logon window to enter your credentials. It works, is little annoying though. To fix this you need to change a setting in your registry:

Regedit
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\WebClient\Parameters] AuthForwardServerList

Adding the URL of your SharePoint server will automatically forward your credentials the next time (after reboot) you open the Explorer View.WebDavAuthForward

SharePoint List and WebDAV

VN:F [1.9.22_1171]
Rating: 0.0/5 (0 votes cast)

WebDAV FehlerEs kommt nicht selten vor, dass Listen mit über 10,000 Einträgen im SharePoint verwaltet werden. Manche User mappen sich auch gerne ein Laufwerk auf eine Bibliothek und laden so Dokumente hoch. Kann ich auch verstehen. Zu welchem Zweck auch immer kann es sein, dass eine Fehlermeldung kommt, dass auf das Laufwerk nicht zugegriffen werden kann. “WebDavParametersis not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions. A device attached to the system is not functioning.” Das Problem liegt nicht wie man vielleicht vermutet auf dem Server sondern auf dem WebDAV Client, in dem Fall der aufrufende Computer. Es gibt bestimmte Einstellungen die in der Registry die gesetzt werden müssen, dass es wieder funktioniert. In dem Screenshot rechts ist das Attribut was geändert werden muss. Dies steht unter: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\WebClient\Parameters]

Danach is ein Neustart notwendig, dass die Einstellungen ziehen.

SharePoint und Kerberos

VN:F [1.9.22_1171]
Rating: 0.0/5 (0 votes cast)

Ich hatte das Problem, dass nachdem ich die Web Application auf Kerberos umgestellt hatte immer ein Anmeldefenster beim Aufruf der SharePoint Site bekam. Nach dem Eintragen des Benutzers und Passwort (3 mal) kam nur eine leere Seite. Keine Fehlermeldung oder irgendein Hinweis wo das Problem liegt. Wenn man die URL mit “/default.aspx” ergänzt hat kam kein Anmeldefenster und die Seite öffnete sich. Schon komisch dachte ich mir. Hier der Hintergrund:

Servername: Server1.mydomain.local
URL des SharePoint: http://portal
SPNs laufen auf “portal” und “portal.mydomain.local”
Public URL des SharePoint http://Server1

Nachdem man die Liste sieht sollte es einem recht schnell auffallen! Da die SPNs nicht auf den Servernamen registriert sind muss auch die Public URL http://portal.mydomain.local sein!

Weitere Artikel zum Thema die ich sehr gut fand ist zum einen der Blog von Michel Barneveld mit dem Beitrag the-reason-why-kb911149-and-kb908209-are-not-the-solution und in dem TechNet Blog Configure Kerberos authentication (Office SharePoint Server).

Diese Seite kann nicht angezeigt werden

VN:F [1.9.22_1171]
Rating: 0.0/5 (0 votes cast)

Es gibt sicherlich mehrere Gründe warum diese Meldung kommt. Was die meisten Admins vielleicht nicht berücksichtigen ist, dass ein AD User in zu vielen Gruppen Mitglied ist. Das alles hängt mit der Token Size zusammen. Ist der User in zu vielen Gruppen werden bei der Anmeldung am PC nicht alle Security Gruppen übertragen da die Menge nicht in den Token passen. Es kann auch sein, dass durch die Änderung von Global in Domain Local Gruppen der Zugriff auf einmal nicht funktioniert. Das liegt daran, dass eine Domain Local Gruppe ein paar Bits mehr hat und deswegen die Gesamtgröße des Tokens sich ändert. Die Token Size kann man in der Registry ändern was aber andere Probleme mit sich bringen kann. Mit dem Befehl Whoami /all können die Gruppen ausgelesen werden. Zu der Gesamtzahl der Gruppen zählen auch die verschachtelten Gruppen!